かべぎわブログ

技術的なことについてかけたらいいな…

Ansibleのバージョンを指定してインストールする

概要

Ansibleの特定のバージョンをインストールする方法をご紹介します!

バージョンを指定してインストール

たとえば、バージョン2.4.3をインストールする場合は以下のコマンドのようにバージョンを指定してpip installを実行します。

$ sudo pip install ansible\==2.4.3

確認してみる

ちゃんとAnsible ver2.4.3がインストールされていました。

$ ansible --version
ansible 2.4.3.0

まとめ

Ansibleの特定のバージョンをインストールすることができました。
検証のために最新版ではなく特定のバージョンで動作させたいといった場合などに役に立つかと思います。

Ansible実践ガイド 第2版 (impress top gear)

Ansible実践ガイド 第2版 (impress top gear)